CVE
CVE-2026-119977
WordPress Foundation · WordPress
- First Reported
- Nov 3, 2026
- Latest Reported
- Nov 4, 2026
CVE Enrichment
- CVSS
- 8.1 HIGH
- EPSS
- 0.60%
- EPSS Percentile
- 48.75%
- CISA KEV
- YES — Known Exploited Vulnerability
Description
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
Technical Details
- CVSS Version
- 3.1
- CNA / NVD Source
- [email protected]
- Published
- 31-Oct-2026 13:16
- Last Modified
- 04-Nov-2026 12:18
- EPSS Date
- 2026-11-03
- CWE
- CWE-367
CVSS Vector
CVSS:3.1 AV:N /
AC:H /
PR:N /
UI:N /
S:U /
C:H /
I:H /
A:H
CISA KEV Details
- Date Added
- 2026-11-03
- Remediation Due
- 2026-11-06
- Known Ransomware Campaign Use
- Unknown
- Required Action
- Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
- Notes
- https://wordpress.org/news/2026/10/wordpress-7-1-4 ; https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-core/wordpress-core-470-713-unauthenticated-upgrade-window-staged-installer-remote-code-execution ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2026-119977
CNA Products / Version Status
- WordPress Foundation · WordPress
Source: CNA · [email protected]
Default status: unaffected
4.7.0 ≤ version ≤ 4.7.38 — affected (semver)
4.8.0 ≤ version ≤ 4.8.33 — affected (semver)
4.9.0 ≤ version ≤ 4.9.34 — affected (semver)
5.0.0 ≤ version ≤ 5.0.30 — affected (semver)
5.1.0 ≤ version ≤ 5.1.27 — affected (semver)
5.2.0 ≤ version ≤ 5.2.29 — affected (semver)
5.3.0 ≤ version ≤ 5.3.26 — affected (semver)
5.4.0 ≤ version ≤ 5.4.24 — affected (semver)
5.5.0 ≤ version ≤ 5.5.23 — affected (semver)
5.6.0 ≤ version ≤ 5.6.22 — affected (semver)
5.7.0 ≤ version ≤ 5.7.20 — affected (semver)
5.8.0 ≤ version ≤ 5.8.18 — affected (semver)
5.9.0 ≤ version ≤ 5.9.19 — affected (semver)
6.0.0 ≤ version ≤ 6.0.17 — affected (semver)
6.1.0 ≤ version ≤ 6.1.15 — affected (semver)
6.2.0 ≤ version ≤ 6.2.14 — affected (semver)
6.3.0 ≤ version ≤ 6.3.13 — affected (semver)
6.4.0 ≤ version ≤ 6.4.13 — affected (semver)
6.5.0 ≤ version ≤ 6.5.13 — affected (semver)
6.6.0 ≤ version ≤ 6.6.10 — affected (semver)
6.7.0 ≤ version ≤ 6.7.10 — affected (semver)
6.8.0 ≤ version ≤ 6.8.11 — affected (semver)
6.9.0 ≤ version ≤ 6.9.10 — affected (semver)
7.0.0 ≤ version ≤ 7.0.7 — affected (semver)
7.1.0 ≤ version ≤ 7.1.3 — affected (semver)
References
- [email protected]
- [email protected]
- [email protected]
- [email protected]
- [email protected]
- [email protected]
- [email protected]
- [email protected]
- CISA Advisory
- 134c704f-9b21-4f2e-91b3-4a467353bcc0
Sources: NVD · FIRST EPSS · CISA KEV
Latest successful provider update; providers refresh independently.
Reported Context (6)
- The vulnerability is tracked as CVE-2026-119977 (CVSS 8.1) and was fixed in WordPress 7.1.4. WordPress Core Updater Race Condition Enables Unauthenticated Code Execution
- WordPress core’s upgrade-window RCE lands in KEV (CVE-2026-119977) Weekly Security Roundup: Binance’s $6.4B Theft, CrowdStrike Acquisitions and Malicious Claude Code Builds
- Tracked as CVE-2026-119977, the vulnerability carries a CVSS score of 8.1 and can allow an unauthenticated attacker to execute arbitrary code on a vulnerable server during a WordPress Core upgrade. WordPress Patches Actively Exploited Core RCE Flaw CVE-2026-119977
- The high-severity vulnerability, tracked as CVE-2026-119977 (CVSS score: 8.1), is a case of Time-of-check Time-of-use (TOCTOU) race condition that could be exploited to achieve arbitrary code execution on affected CISA Confirms Active Exploitation of WordPress Core Flaw
- Tracked as CVE-2026-119977, this high-severity WordPress Core flaw stems from a Time-of-check Time-of-use (TOCTOU) race condition and was reported by Picus Security researcher Umut Bayram. CISA Flags WordPress CVE-2026-119977 as Actively Exploited
CVE (6)
Malware (2)
People (5)
Threat Actors (3)
MITRE ATT&CK (3)
Vendors (11)
Products (9)
Tools (2)
Industries (4)
Countries (3)
Note: Related entities, including threat actors, malware, CVEs, MITRE ATT&CK techniques, vendors, products, tools, countries, and industries, are shown when they appear in the same reporting. Their presence does not necessarily mean they were targeted, compromised, vulnerable, responsible for the activity, or directly involved in the incident.
