Cisco Patches ISE and Webex Flaws That Could Enable RCE and User Impersonation

· Original article ↗

Summary

Cisco patched three ISE vulnerabilities that could enable command execution and privilege escalation, plus a Webex SSO flaw that could allow user impersonation. Cisco reported no known exploitation; no workarounds are available.

Key points

  • CVE-2026-20147 affects Cisco ISE versions 3.5 and earlier; an authenticated attacker with administrative credentials could execute commands and escalate privileges to root.
  • CVE-2026-20180 and CVE-2026-20186 affect ISE versions 3.4 and earlier; attackers with read-only administrative access could execute commands.
  • CVE-2026-20184 affects Webex Services deployments using SSO with Control Hub; improper certificate validation could let an unauthenticated remote attacker impersonate users.
  • Cisco said it was not aware of public exploitation or malicious use when the flaws were disclosed.
  • No workarounds are available. Cisco released fixed versions, and systems earlier than ISE 3.1 should migrate to a supported release.
  • Cisco warned that exploitation in single-node ISE deployments could prevent new endpoints from authenticating.

Article Details

Vulnerability Types
  • Insufficient validation of user-supplied input
  • Improper certificate validation
Severity
Critical; CVSS 9.9 for the ISE vulnerabilities and 9.8 for the Webex Services vulnerability
Affected Versions
  • Cisco ISE 3.5 and earlier (CVE-2026-20147)
  • Cisco ISE 3.4 and earlier (CVE-2026-20180 and CVE-2026-20186)
  • Cisco ISE-PIC systems, regardless of configuration
Exploitation Status
not_reported
Exploit Availability
unknown
Patch Status
available

MITRE ATT&CK

CVE

People

Vendors

Products

Related Articles